Search for content in message boards

Is FTM 2012 REALLY slow?

Replies: 31

Is FTM 2012 REALLY slow?

Posted: 12 Oct 2012 2:18PM GMT
Classification: Query
Edited: 16 Oct 2012 6:25PM GMT
Hi,
I have recently re-installed WinXP and now FTM 2012 is nearly unusable. Unfortunately, before I could test FTM, the mandatory update was installed. The update corrected lots of functional issues but FTM2012 launch time is now about 1.5 min. I don't have any hard times, but I believe before I made the changes, launch time was about 30 second. After launch, If I click the Sources menu, the screen is not totally populated for 1 min. 45 seconds (a REALLY long time). Is anyone having a similar issue since the update?

Sturdy2

Edit: I forgot to mention sync now takes about 4 hours!

Edit: Oct 16, 2012 Just to close the loop in this thread: My problem with a SLOW FTM is confirmed to be my old WinXP installation. Removed everything and re-installed and now there is joy in Mudville tonight. Launch time is now about 15 seconds; Time to the Source menu is now about 5 seconds; a small sync completes in about 5 minutes not hours.
SubjectAuthorDate Posted
sturdy2 12 Oct 2012 8:18PM GMT 
tulrose 12 Oct 2012 8:28PM GMT 
sturdy2 12 Oct 2012 8:42PM GMT 
gldaggett 12 Oct 2012 10:45PM GMT 
jnye042 12 Oct 2012 11:05PM GMT 
johndd189 13 Oct 2012 1:00AM GMT 
ad4hc 13 Oct 2012 7:28AM GMT 
sturdy2 13 Oct 2012 2:08PM GMT 
jamclo 13 Oct 2012 5:05PM GMT 
tulrose 13 Oct 2012 5:12PM GMT 
per page

Find a board about a specific topic

  • Visit our other sites:

© 1997-2014 Ancestry.com | Corporate Information | Privacy | Terms and Conditions